BME 280 not found

with our slovak colleague we have problem with getting any data from the BME280. The SDS011 is fine.

Tried 2 different BME280 sensors, different wiring, firmware etc. still in debuging is:
Read BMxE280…
Trying BMx280 sensor on 76 … not found
Trying BMx280 sensor on 77 … not found
ChecPM10: 9.20
PM2.5: 5.15

Any ideas highly appreciated, thank you!

1609226818214blob 1609226968461blob

did you also try the pins GND and 3V directly beside the pin D4?

Hello Ricky, yes he tried that too. It’s on the last photo. That was my first suggestion but unfortunately he didn’t succeeded.

Did you try another wires to eliminate HW problems?

Yes, I have tried also wires I use for SDS. Result is still the same.

Just as a quick test - try to set BMP180 and unset BME280 in config (and save of course!)

I got this in the debug:

Read BMP…
No valid BMP085 sensor, check wiring!

And no results were provided


I have exactly the same issue
I bought 2 BME280 sensor to be sure, same issue with the both, no data :frowning:
I think my wires are correct, like you

Let’s start with the trivial stuff : did you solder the pins yourself ? Have you looked for short circuits ?
I had a NME280 which stopped sending data : it was because of the rost.

1 Like

I didn’t solder the pins, just plug it in (see photo). Perhaps not enought and no contact so :frowning: I’m going to solder it :slight_smile:

did you solder the pins yourself ?

I didn’t solder the pins, just plug it in

If you haven’t soldered, it should be the reason. You’ve just put the pin though the hole and plug it on the other side, haven’t you ?

As I told to another user in another question in this forum: read the instuctions attentively and do exactly the same steps unless your have perfectly understood how the sensor works…

Rome was not built in one day (a French phrase) and the first architects have probably built the forum according to classical instructions before experimenting…

And as always: the trivialest thing is the solution…

1 Like

Yep it should be the reason. I thought it’d work even without the solder. That the connection’ll work just with a simple contact. I’ll do the solder so :slight_smile:

Yep I think that “Rome ne s’est pas construit en un jour” :slight_smile: I’m also native french speaker :wink:

thx a lot

Same for me. I had soldering on one pin only to keep sensor attached. After all 4 pin were soldered, everything works fine. Thank you.

Can someone tag this thread as “SOLVED” ?