BME280 not working

I have bought this set Nettigo: KIT (SDS011/BME280), English language and build it together. Works but not data from the BME280.

Checked wires, replaced wires, bought a new BME280 but no succces. Tried to flash with the original Luftdata and the new airrohr flash tool. Tried to flash latest.bin, tried to flash the BME280.bin but still no data. Perhaps the NodeMCU 3 broken?

could you please post a screenshot of the status page and the page with the actual values?
The chipID would also be very helpful.

This one?

And the connection

Can I see the solder points ? It looks not well soldered… This was so here: BME 280 not found - #9 by pjg
As I always tell: if it is the fisrt time you build a sensor you must do exactly what is described in the instructions.

Yes, I saw the post and it’s well soldered. One from the kit was already soldered and the other one done by me.

Thanks guys, I flashed the board again and suddenly it’s working with the new sensor. Thanks for your input.

1 Like

It looks basically good. Could it be that because of a short circuit pins of the NodeMCU were inactivated ? Haven’t you made some mistakes while you plugged the sensors ?

The kit sensor was faulty and the new sensor works fine. Maybe it had to wake up by reflashing? Don’t know but I’m glad it’s working after 3 days trying :slight_smile: