BMP280 Not Sending data

Following my replacement of the MCU (see Broken USB socket, deriving power via Vin

I have attempted to set the unit up as before.

It appears that the SDS011 and the DHT22 are both working correctly, but the BMP280 is not, despite being registered. I have double checked that the unit is wired correctly and power is in fact present on 3V3 (3.29V). This appears to be confirmed by monitoring the serial O/P.

Do I have a configuration issue?


Can we see the solderings of the BME?

Did you check the voltage on the BME280 breakout board or at the mcu?
Did you check the conductivity of the 4 leads?
And as Pierre-Jean suggest the soldering of the BME280 is often the culprit.

Pictures as requested

Voltage checked at the BMP280. I have also checked continuity of all four leads and they are all OK.

It might be a red herring but I believe the sensor to be a BMP280, but notice that both yourself and Pierre-Jean refer to it as a BME280. Is this significant?

BME → is humidity + pressure + temperature
BMP → pressure only

Check your connection once again! There might be a loose connection.
VCC → Pin 3V3
SCL → Pin D4 (GPIO2)
SDA → Pin D3 (GPIO0)

Also change the language of firmware (it will make it reload FW). Might be some FW “cach” problems.

Your soldering looks OK.
BMP280 should give temperature as well. For the firmware not a problem. In the log is says BMx280.
Chinese bought units are known to have fake Bosch sensors. The markings on your unit look suspicious. No manufacturer name. Usually chinese units read "GY-BM. Consider testing with an Arduino I2C scanner [software sketch]. Maybe uses a an unknown I2C adress

Aah GY-BM is BME280 and HW-611 is BMP280.
Unit should work on I2C adress 0x76 which the firmware does check… So does that leave a fake sensor as the cause?

Useful info thank you. However this unit was working satisfactorily (for over a year) in the original make which rather suggests that even if it is a fake, it was nevertheless working originally.

I have downloaded the scanner sketch and can confirm it reports a Device found at 0x76 after connecting the BMP280.
I will see if I can find a sketch to output the data to the serial port, just to be shure.

I have run an adafruit sketch ‘bmp280test’ and it outputs:

Temperature = 24.31 *C
Pressure = 99067.37 Pa
Approx altitude = 189.68 m

So I believe this proves the sensor,

Good research. Your firmware is up to date. Did you try the scanner sketch on the mcu in use for the dustsensor? Now is seems that the the mcu is problematic…

Yes, I agree MCU does look a likely candidate. Today I connected the BMP280 to the old MCU (powered via Vin) and all works fine.

I wonder, is it significant that at the time of flashing the firmware I don’t think the BMP280 was connected, I connected it later. I see other posts suggesting that adding sensors can be problematic (just a thought).

I will try to re-flash, but this time with all three sensors in place, will that cause any issues?

If this doesn’t cure then I suspect it is a rebuild with a new MCU.

Interesting, I tried unsuccessfully to refresh using 0.3.4 Windows64. Looking at the configuration only two sensors have been found SDS011 and BMP280, no sign of the DHT22 this time (I assume it should be able to ‘see’ all connected sensors?

Also unable to find port CH340 (short USB cable, running as admin)

I have put off changing the MCU as this means a complete rewire, however I guess the time has now come.

When attempting to flash the MCU (using Airrohr Flasher v0.3.4, but have also tried v0.3.2 just in case) I get the error “could not open port ‘COM4’: PermisionError(13, ‘Access is denied.’, None, 5)”

If I run as administrator error changes to “Failed to connect to Expressif device: Timed out waiting for packet header”

I have checked in the device manager and USB-SERIAL CH340 (COM4) is listed as working properly.

Firmware version is ‘latest_en.bin or latest.bin’ although I have tried others, results are the same.

Short USB cable used (with data capability)

Any suggestions as to a way forward appreciated.

Das ist typisch Shortcuts because of the I2C. Unplug the bme 280 before flashing.

Thank you for that, now sucessfully flashed. But I am now back to ‘square one’ as in: BMP280 Not Sending data - #11 by tadder.
I’m clearly going in circles, am I missing something?
Just to be clear I am getting data from both the SDA011 and the DHT22, but nothing from the BMP280.