Forum Sensor.Community

Sensor cannot send data any more

Hi. My Sensor can not send data to the apis like the community or madavi. I run this sensor for about 2 years now and all works fine for all this time. For about the last 4 month it works only for some minutes or hours a day,if any. The sensor is reachable from wlan, as well as from the web, it sends data to my own server, but no data are send to other servers. Nothing has been changed here. What can be the reason?
Firmware: NRZ-2020-133/DE (Nov 29 2020)

Regards,
Herbert

Hi,

it sends data to my own server, but no data are send to other servers

Are you sure ?

Please give me the ID of the ESP board. I will check when it stopped exactly.
Do you know how to connect the Sensor on a computer in order to read the log (for example with the Arduino IDE) ?

In my opinion, the pin/connections oydized and created a short cut. It should be reversible : use an old toothbruch and spirit (or better desoxydizing fluid) to wash gently the pins and the soldering on both the SDS011 and the BME280. Of course remove the plug before.
It should work.

Hi.
Sensor ID is 325848. Sometimes ist works for minutes, sometimes for hours. Before it worked continously for month.
I will check the contacts on weekend.
Thanks for now.
Bye

I have already seen this at someone’s in Germany. It seems to regular to be honnest on the graphics… Can you give the ID on the map because I would like to download the whole archives for the day It works.

Capture d’écran 2021-03-11 à 10.43.30

Could it be that certain providers “refuse” to send SC-Data at certain hours ?

Do you have a Fritz!Box? If yes please check if the DNS resolving is configured to use DoT (DNS over TLS). This seems to cause problems. With that the resolving seems to take too much time.

my sensor BME280 doesn’t send any data but the PM sensor yes… do you any idea of that problem?
thank you.

Can I have screenprint.

it is probably oxydation.

It s a new sensor, Just 2 weeks ago i activate It.

Please send pictures and the board ID. Has it worked once or not ? If not it is probably a problem with the cables/connections. Did you triple check the pin numbers ?

my Node id is esp8266-10217304. no, the Be280 has never sent data. i check ti pin numbers, they’re seemed ok

Can I see the way you soldered the pin on the BME280 ?
Did you choose BME280 in the configuration page AND the registration page ?
I can’t discriminate the yellow and the orange cable but it should be ok for the connections.

sorry Jean Pierre, I had selected the DHT22 sensor instead of BME280 in the configuration.
I’m sorry if I wasted your time. Now it’s ok and all data are sent.
thank you very much

Too easy… :slight_smile:

You’re welcome !

I found the reason for the problem.
In November 2020 AVM released a new firmware (7.21) for the Fritzbox 7590. Since then sending the data failed in most cases. Last week i installed the new VERSION (7.25) and sending data now works very well again. With 7.21 in the esp log a sending time of 54000 ms was shown and only madavi received data, but only for hours. with 7.25 the data can be send to all servers within 3-4000 ms. What these strange behaviour caused, i don’t know.

Thanks for supporting

H.Brandner

This seems to be connected to their new DoT (DNS over TLS) name resolution “feature”. This is activated by default. But some of the DoT servers seem to be overloaded and won’t resolve in a timely manner. Looks like they solved this with the update.