Forum Sensor.Community

SDS does not work anymore

Hello @all,

I was operating a SDS011 here at home for quite a time without issues.
Since some time the sensor does not transmit any data to luftdaten.
Attemps to reboot the sensor have not been successfull :frowning: So it took some times until I was able to dismount the sensor and make further checks.

What is the status of my checks?

  • The ESP seems to start. The blue LED flashes whith power on
  • There ist no wifi opened by the ESP
  • The wifi it should connect to is up and running. Open network, so no password required
  • I can’t connect with the serial monitor from the arduino ide to the ESP (using 115kB). At least I do not see any output on the console.
  • On the lower side of the SDS011 a red LED switches on and then starts then to blink.
  • The fan of the SDS is turning, but switches off after some seconds. That seems to repeat from time to time

So there is not much to identify for me.
Any idea what the failure cause and some remedy could be?

If the ESP cannot connect to your network, my guess it will not start default operation mode.
If you cannot enter the setup page of the sensor because it is not connected to your network it will be setting up it’s own network.
Connect to that network which begins with airrohr…
You can access the device on
http://192.168.4.1/config
Maybe you van troubleshoot from there

Good luck

If I remember correctly the firmware is set to use 9600.

Thanks for your hints.

As already mentioned the ESP does not span a network. So no chance for that.

I tried setting to 9600. But also there no response at all.
Even with the baudrate set wrong I would expect some - maybe unreadable - output from the ESP.
Such output is mostly an indication of wrong communication params.

Any information about the blinking LED on the SDS? Is that correct?
How does the ESP (re)act, if the SDS does not work? Only some debug output?
One check for a defective ESP could be to flash a new ESP with the software. Where can I get the latest build of the software?

It flashes in normal operation once approx. 3 seconds at least mine does with oled attached
My guess is that your ESP is broke.
Since it is a relative cheap part I would buy a new one
You could try to connect gnd to gpio0 or press the flash button to go into bootloader mode and while keeping pressed the flash button connect your ESP to the USB port.
Maybe the your USB connection Will work again
Perhaps your bootloader is damaged and it is the not recognized by USB
Do you see the serial port in your device manager?
I had a problem with a WEMOS D1 mini pro, connecting gpio0 to gnd and the connect to USB solved that problem for me

@luftiger As you wrote the SDS011 is stopping after restart and restarting from time to time. This is the normal behaviour. The SDS011 is “shut down” every 2 minutes and then running again for 20 seconds. With that the life time of the sensor should be much longer than the 8000 hours (less than 1 year) when running continuously.
It looks like the connection between TX on the SDS011 and D1 on the NodeMCU doesn’t work. Commands like start and stop are received by the SDS011 but the data can’t be received by the NodeMCU.

Thanks for the support.

It took me some time to get the material, the required firmware and flash intructions.
So I flashed a new ESP with the firmware I found on Index of /sensor/update/data (latest.bin)
I used the Arduino tools to flash

C:\Users\XXXX\AppData\Local\Arduino15\packages\esp8266\tools\python3\3.7.2-post1/python3 C:\Users\XXXX\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.4/tools/upload.py --chip esp8266 --port COM6 --baud 115200 --before default_reset --after hard_reset write_flash 0x0 D:\drivers\airrohr\bin\latest_de.bin

That worked all fine, no errors.

I started the ESP, found the WiFi and defined the required data for the WiFi connection, reboot the ESP.

Then I checked

//api-rrd.madavi.de/grafana/d/Fk6mw1WGz/wifi-signal?orgId=1&var-chipID=esp8266-XXX&theme=light

but no data arrives.
The ESP does not log any data on the Arduino Console.
What else could fail after setting the parameters on the ESP?
What other checks could help to identify the root cause?

@luftiger Did you check the cables, as mentioned in my last answer? There was nothing said about flashing the firmware again. And where did you get the link to madavi.de? In our instructions at https://sensor.community/ you would have found all needed informations including a link to the flashing tool that would download the firmware from the right server …

When replacing the ESP this was absolutly required.

Apologise my misbehaviour in that case. But following this proposal

I was forced flash the new ESP as did not come with the correct firmware.
Flashing another sketch showed that the flashing and USB communication is working fine.
I received also debug information to the console.
The flashed airrohr software did work well. At least I was able to configure the ESP and do a reboot.
But I do not reveive any debug information from the airrohr firmware.

You are right with that statement. But that would require to install another software just for flashing the ESP with the airrohr firmware.
The only thing missing on your page is (the link to) the firmware.
Maybe you might be so kind to give me the correct link to the actual release of the airrohr firmware?

The path to the actual firmware releases is:
https://firmware.sensor.community/airrohr/update/

Please send a photo of your assembled device. So we can check that the cables are connected to the right pins.
There are 2 versions of the NodeMCU module. You should also check that the pins the 5V and GND pins of the SDS011 are connected to on the NodMCU are labeled with VU and GND. The other board version is labeled ‘RSV’ (reserved) and won’t power the SDS011. In this case the VIN and GND directly beside the USB port need to be used.

Thank you. That was the first step towards solving my issues.
I’ve got some of these modified Node-MCUs with PWR on the former used pins.
Powering the SDS gives me now the long awaited debug on the console.
This tells me that the SDS is responding, measuring and returning the values. Great news.

Now there still is a problem sending the data to

Sending to sensor.community - SDS011

Request failed with error: 403
Details:{“detail”:“Node not found in database.”}

The sensor# returned from the SDS is not the same as before!

The data send to madavi is visible unter the new sensor ID but comes without history. The sensor ID does not have new data.

How can a sensor ID change?

You have replaced the NodeMCU. In this case the chipID will change. If you send me the old chipID and the new on then I can replace this in the database .So the sensor mill show up under the old database ID on the map.
Madavi is using only the chipID (without any registration). That’s why a new NodeMCU won’t have any historical data.