Registered SDS011 - No Data

Hi sensor-community,

flashed my NodeMCU v3 ESP8266 CH340G with latest.bin
configured SSID & PW - noted "ID: 7509550 "

Saved configuration and start

can see the airRohr-7509550 now on my WLAN
registered my SDS011 with noted “7509550” as esp8266-7509550
shows WiFi-signal, but “No Data”

Please, what can I do, to send data?

Please send me pictures of each tab:

  • More setting
  • Sensors
  • API

How are they configured ?

Is the configuration in the same ?
Have you read the whole instruction on the website attentively ?

thanks pjg,

configuration in says:
sensortyp SDS011 - same as configuration - SDS011

Read whole instruction, but didn´t find a way to check the SDS011, except SDS011 liefert keine Werte NRZ-2020-133/DE (Nov 29 2020) · Issue #875 · opendata-stuttgart/sensors-software · GitHub
Didn´t yet find a way to connect the SDS011-Port with PC to run the sensor-test.

No BME ?
You can use an USB to TTL dongle to test the SDS but it could be tricky.
You could also read the Logs of the sensor.
Do you have Arduino IDE in your Computer.

Are you sure câbles are well connected ? Did you triple check ?


no BME at the moment

If you mean “Debug level” when mentioning “Logs”, then I see endless repeating like :
Time for Sending (ms): 56
ws: values …
ws: root …
ws: values …
*## Sending to *
Succeeded -
Time for Sending (ms): 158

Yes, I have Arduino IDE, tried to connect ESP8266&SDS011 but yet didn´t find all libraries to succeed compilation…


irritates me - I soldered according
TXD → D1
RXD → D2

…should I better connect to RX and TX at the board?

No it should be right.
But are you sure of your solder ?

Please try to find someone expérienced with microcontroller who can read the usb logs.
Where are you living ?

thank you pjg - I had opportunity to test my circuit with another SDS011 which worked fine - seems I wrecked my SDS011 during installation.
I like the idea to see SDS011 at arduino-IDE-monitor …