No display, no measures with NRZ-2024-135


I just grabbed a new NodeMCU and flashed the new NRZ-2024-135 firmware. Worked fine, connected to my Wifi, set my hardware (SH1106 SPS30 and BME260) and went over to my running sensor with NRZ-2021-134-B4/DE firmware

Unplugged the cables, put them in the exact same pins on the new NodeMCU board, power on and… nothing.
Display stays dark, Wifi works, no measures.
Re-plugged the old board and it works.
Re-Flashed the new board, exact same result

Did you change the Pins with the new firmware? Using D3 and D4


NRZ-2024-135 has the same definitions as NRZ-2021-134-B4. The only change between those versions which is related to displays is the used library for ThingPulse/ESP8266 and ESP32 OLED driver for SSD1306 displays (also used for SH1106). That was bumped from 4.2.1 to 4.3.0 (4.2.1 not being available anymore in the platformio repo and 4.3.0 being the closest one).

Hi, @[Troubadix, How looks the debug information when you connect new NodeMCU (NRZ-2024-135 firmware) to USB port and use a serial monitor application? and do the same with old NodeMCU (NRZ-2021-134-B4).

BTW what happend when jou flash new NodeMCU with the /FijnStofGroep/sensors-software-Leusden version?