Forum Sensor.Community

Issues with August 22 beta release?

It seems that a few users have trouble after their sensors attempted to do an OTA update to the current (yesterday’s) beta release. There are two threads on github (915 & 916). Are you aware of the issue @ricki-z , @pjg & others?

The first thread (915) isn’t related to the beta release. The user has checked it and he is using the release version.
To the second one I have sent an answer.

I have beta firmware and automatic update on on all my 3 sensors.

They all stopped working on Saturday 22nd.

Should I just flash the latest stable firmware, to solve the problem?

@thatent Yes, please try this.

1 Like

Hello, I had problems with the OTA update too. It just stopped and showed that:

▒EO|t`MM
▒lb<l▒4:h▒▒▒airRohr: NRZ-2021-134-B4/DE
mounting FS…
opened config file…
parsed json…

No more access via HTTP from the sensor possible, ping worked fine. Furthermore, no more sensor data were sent, I installed a stable version and it works fine again.
greetings

1 Like

I’ll try it this weekend and hopefully my sensors will be back on track soon! Thanks for the help.

@ricki-z Many people in Bulgaria have the same problem. Where we can find the beta release before 22 august? It was very stable.

@Petar Same question back as on Github:
Why do these people use the beta version? The beta is meant to be used for testing purposes and newest features.

For me it was because I then could test the firmware, and report if something wasn’t entirely ok. I never expected the whole device to become temporarily unusable- not complaining tho, running beta software always comes with a risk!
I will be sticking with stable from now on.

1 Like

@ricki-z There is no problem people to go back to the stable version, however I reported that it is not single and isolated case. I think that more beta testers means more stable version.

From my experience there is an alternative to go back to stable. If you want to run the current beta here are the steps that worked on my two sensors:

  1. Flash Aug22 beta (sensor will still not work)
  2. Flash an older release. In my case I had older betas stored locally. I have not tested this workaround with the Nov 2020 stable release. Make sure that you always use the same language version of the firmwares
  3. Activate OTA. The sensor should now be able to update to Aug22 and run as expected.

This is my experience and no official recommendation by the developers.

Beta testers:
We haven’t got so much feedback from beta users for the last versions. And a feedback “doesn’t work” isn’t really useful if there are only few people developing (at the moment 1). So if people can’t read the serial output of the sensor and flash it again with a stable version it the case of a problem like this time then it would be better to use the stable version. (Sorry if this sounds a little harsh but ‘doesn’t work’ really consumes time we could use to solve the problem :wink:)

What I’m looking for is a repeatable way to flash a NodeMCU with an old so that a direct update to the buggy beta is causing the actual problem. The beta firmware is working and the config of the actual release version can be read. So it’s not a change in the file system. It’s a step in the upgrade process that isn’t working as expected … At the moment I think that there is a mismatch in the MD5 send by our server and the MD5 calculated by the flashing process of the intermediate firmware.

At the moment I think that there is a mismatch in the MD5 send by our server and the MD5 calculated by the flashing process of the intermediate firmware.

If that is the case would this also affect a direct flashing of the firmware? I am asking because in my case the sensors did not function after flashing the latest beta.

Following the comments on Github these steps should work:

  • flashing latest release
  • OTA to latest beta
1 Like

Hi everyone,

I have only now had time to try to flash the stable release to my three sensors. I’m having an issue though. Trying to flash firmware, using the AirrorhFirmwareFlasher, fails with the following error messages:

Connecting........_____....._____....._____....._____....._____....._____....._____
ERROR:root:Unhandled exception
Traceback (most recent call last):
  File "/home/nrz/airrohr-firmware-flasher/airrohrFlasher/utils.py", line 32, in run
  File "/home/nrz/airrohr-firmware-flasher/airrohr-flasher.py", line 297, in flash_board
  File "/home/nrz/.local/lib/python3.6/site-packages/esptool.py", line 245, in detect_chip
  File "/home/nrz/.local/lib/python3.6/site-packages/esptool.py", line 452, in connect
esptool.FatalError: Failed to connect to Espressif device: Timed out waiting for packet header


Does anyone know how to deal with this? It is happening on all three sensors that stopped working after the August 22 OTA update. I’ve tried flashers version 0.3.0 and 0.3.2 on Linux.

Thanks a lot in advance if anyone knows how to deal with this!

Update: I’ve tried the whole morning and I’m not getting anywhere with this.

The light still work on the boards, and whenever I try to flash, the blue light continuously blinks and lights up.

I just flashed the firmware to a new board that I have never used before and it flashed beautifully - it’s not the computer. I am sure the boards that were messed up because of the BETA firmware are not dead because the lights still work and the port is auto-detected, but I just keep getting this error message:

esptool.FatalError: Failed to connect to Espressif device: Timed out waiting for packet header

I’m basically stuck with three boards that I’m sure are not dead but I just can’t figure out how to flash the firmware to it. Any help would be greatly appreciated!

Searching for this message I found several recommendations

  • used a different port on your computer
  • press and hold the nodemcu’s “flash” button while uploading the firmware
  • hold “flash” button and press “rst” once

Not sure if this helps… I also had issues flashing firmware under Linux. It worked perfectly on my Mac.

1 Like

Thanks so much for this! I have tried several things already, but I’ll give this another go. I’ll report back once I’ve something new to tell! :slight_smile: