Display sensor on map.sensor.community and using an air quality lamp from the project stofananas together with a sensor

Hi everybody,

I teached a class at a school in Beijing building the sensors and the stofananas air quality lamp. One of the pupils has the problem, that the sensor doesn’t show up on the map and lamp doesn’t show the right colors.

He first used the place of the school and it worked so far. Then he changed the geodata as he wants to install the sensor at his parents place. Now the sensor is not showing up anymore.

Some questions I have:
How long does it take that a started sensor, which is successfully uploading data to api.sensor.community and madavi (showed in the sensors log), is showing up at the sensor.community map?
What happens if the sensor is taken offline? When is it not anymore displayed at the map?
The sensors place can be changed, can’t it?
For the geodata the address is not neccesary, if longitude and latitude are filled out, am I right?

Thank you in advance!

P.S.: Maybe the sensor number helps, it’s esp8266-10735650

1 Like

Is the sensor registered on devices.sensor.community ?

Yes, I should have added that number, it’s 80394

I just realized that one of my own sensors (not the one discussed here) is not shown anymore. It’s an indoor sensor. I vaguely remember it was shown on the map before and my outdoor sensor is shown an the map. Are indoor sensors not shown or not shown anymore?

The sensor discussed here was registered as an indoor sensor, maybe that’s the reason? I asked the student waiting for his answer.

The indoor sensors are not displayed by default anymore. You have to check a checkbox and they still are displayed as grey.
Please put your sensor outside! Indoor air is no common if you lock your door!

Thank you for your help! The sensor was changed to a standard (outside) sensor and is displayed on the map, now. During tests he was inside and correctly configured. Now we know that and have to configure the sensors “wrong” to test it together with the stoflamp.

It was just a test and I fully understand and support your idea, that only outside sensors relate to this project and the default is not showing indoor sensors.

But I didn’t find the checkbox for display them in grey on the map. Better to use this way than to configure indoor sensors as outdoor sensors and mess up the database. it’s not related to “Publish exact location”, is it?

I have one more question. Using a “stofananas” for displaying the airquality through the light of a lamp (see here) the data from your database is used. But it’s downloaded from https://stofradar.nl/ the make reactions on future api changes at sensor.community easier. The data is than weighted by the software which turns the lamp into the correct color.

My question: Is the configuation change for your map (not showing indoors sensors by default) changing your apis behavior, too?

Thank you!

The changes concern the map not the API.
The API call should work the same as before.

I own the stofradar.nl domain and run the software behind it.

The value you get from my REST API is an inverse distance weighted average of the PM2.5 of particulate matter sensors some radius around the provided coordinate. The sensor.community API does actually report indoor sensors too, but my software actively ignores these indoor sensors.
Data is retrieved from sensor.community once every 5 minutes.

I recently changed the format slightly, it now also reports up to three closest sensors, for example for the city of Gouda in the Netherlands:

The sensor with plain id of ‘22786’ is a sensor.community sensor, the one with the “LUC_” prefix is a sensor from a different dutch particulate matter project that doesn’t share its data with sensor.community. This number is also the sensor number shown on maps.sensor.community

You could also query this sensor directly using the sensor.community API: