Can't flash nodemcu v3

I try to reflash my nodemcu v3.
macOS 13.6.4
arduino IDE 2.3.2
dowonloaded CH341SER and installed.
nodemcu v3 isn’t recoginzed by arduino IDE.
A new nodemcu v3 either not.
Original Arduino Boards are no problem.
Arduino IDE should show the port, but it doesn’t.
I installed it on an older laptop, without success. Something I do wrong with the driver for nodemcu v3.
Any help would be apreciated.

I think you are now using a USB cable that can only be used for power and is not suitable for data.
I hope this is of some use to you.



How come you are using the Arduino IDE to flash a SC firmware ? It is written nowhere in the instructions…
The firmware can be flashed with the flasher or with Platformio only.

In you case, it is basically an issue with the driver CH341…

1 Like

I tried different USB-Cables, different Systems, different Computers…
The nodemcu V3 (different models) aren’t visible.
Neither Arduino IDE nor with AirRohr Flashing Tool.
My intension is, if it would be visible with Arduino IDE, it could also be flashed.

Could you please send a picture of the modules?
There are so many possible reasons for this. I.e. we had user that ordered the cheapest modules and didn’t solder the pin headers to the board …

Yes, I will do so tomoorrow

Sorry, I just had some other trouble…
Here are thi pics:

  • left is that one that worked well, but I have forgotten the password.
  • right is the new one I ordered
    Both won’t be recognized on my Macintosh-Computer (now with System 14.4)

@doktormac There is a chip right below the usb port. Please check what it is labeled. This should be labeled CH34… to work with the mentioned driver. But there may be boards with another chip that may need another driver.

I had a “fake” NodeMcu and was labeled CH340 (backside) but the USB chipset was a FTDI

Both boards (one that worked before I changed the password) has a CH340G chip.
As I have written:

  • It worked with AirRohr Sensor for several years.
  • Unfortunately I change the password, can’t remember
  • I would like to reflash it with macOS 14.4.
  • I tried with other mac Systems.
  • It isn’t recognized.
  • I downloaded: * für V3: Entpacke den Ordner CH341SER und doppelklicke auf die Anwendung SETUP.
  • Starten deinen Mac neu

MacOS nowadays has native support for the CH340G chipset. Did you try without installing the additional drivers?

Another problem are the MacOS security settings. They are changing from version to version.
Open “Security” under system settings and check if you need to allow the driver to be loaded.