BME280 Not Sending Data (7 Different Sensors)

Recently we have built seven air sensors with a group of students. Flashing, wiring etc. worked completely fine, but unfortunately none of the BME280 units is able to send data to the server.

Dust data from all SDS011 is transferred successfully, but for the BME280’s there is always shown a “no data available”.

We also checked other spare BME280 due to potentially failed soldered points, but still the same issue. Also wiring has been checked a thousand times - nothing helped. We ordered this BME280 directly from China: eBay-Shop: DIY-Arduino

So my questions are:

  • Is there some known problem with the firmware of the NodeMCUv3 when connecting to BME280?
  • Our sensors have a coding “GY-BM ME/PM 280” (see pictures below). Maybe the reseller has sent the wrong sensors (BMP instead of BME) - how could I verify this?

Here you can find two pictures of our BME280 models that we’ve purchased:

Thank you very much for your help!

Due to new registration I had to paste the second picture into another posting:

Where did you source the sensors? There are fake ones known on the market.
Are u able to check if you can get an i2c address with an Arduino and a i2c scanner?

This is what a legit Bosch BME280 looks like:
Schermafbeelding 2022-12-21 om 00.42.21

1 Like

Thank you very much for your approach! :grinning:

Those issues with our BME280 have been quite easy to solve:

Initially, we strictly followed the official installation instructions, but they were wrong. Instead of firmware “latest_en.bin” we had to flash “latest_en_bm280x.bin” - now everything works fine! :wink:

Glad you solved the problem!