Forum Sensor.Community

Airrohr wifi access point asking for password

Hi everybody!
I had trouble to connect a LCD2004 to a freshly flashed NodeMCU V.3, than tried a second display but without success, both displayed only small rectangles. After hours of not understanding I found out both have 0x3F as I2C address.

I have another sensor with firmware NRZ-2020-133/DE which has actually a driver for the LCD2004 with this address to choose at the config page.

I tried to flash the ESP8266 with the dev-version of the airrohr software. First it wouldn’t restart the webserver, after I have added the access point name and data and pushed the save and restart button.

I flashed again, added the AP name and password - again it didn’t start the server after that.

Finally - I don’t exactly remember what I did - after again flashing it it restarts and gives me an access point , but it asks for a passwort and shows the AP is encrypted! Even reinstalling the dev-firmware, erasing all with esptool.py

esptool.py --port /dev/ttyUSB0 erase_flash

or only the spiffs with

esptool.py --port /dev/ttyUSB0 write_flash -fs 4MB -fm dout 0x10000 ppd42ns-wificonfig-ppd-sds-dht.spiffs.bin

and later

esptool.py --port /dev/ttyUSB0 write_flash -fs 4MB -fm dout 0x00000 latest_en_dev.bin

I still get the access point but it asks for a passwordI don’t know which one to use. I must have done something stupid.

Any idea what to do?

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

That’s how it’s showing the password encrypted AP at my android phone. Same with my linux laptop.

Screenshot_20210502_141730

The password is ‘airrohrcfg’ (without the quote signs). We got many requests to set a default password so that the sensor hotspot isn’t shown as open if the device can’t connect to a wifi network.

1 Like

I think that’s very good! And thank you for the pw.