Access to sensor page via local network


I have an issue with connection to my sensors page via local network, doesn’t matter is it PC, either phone. When I type assigned LAN IP, ex. sensor page is not loading and I got error message about to long waiting time. Sometimes page load after few minutes, but for example for last 3 days I couldn’t load it, even after reboot. However from other side sensor are working, because I data which are transfer to sensor community, so do madavi. Sensors have assigned static IP and they in good range of router, even when temporary I moved them to the same room and they were 2m from router, I had this issue.

Please use the firmware flasher’s “search tab”:
Capture d’écran 2022-09-27 à 06.11.55

You will see the actual IP addresses and you can double click on an address directly to open it in the browser.

But I know sensor IP address and after connection directly via browser after few second I have error about connection time out. Today I tried also via software. Sensors were discovered after few minutes and after I double click on it, I had same effect. I tried also different browser, Chrome, Firefox, so do MS Edge, same effect. All sensors have full wifi range (as I see it on router page).

What you describe is connecting to a sensor which is not configured. Please use the flasher or get the IP in the DHCP Client list of your router.
Are you sure you confugured the wifi on the Sensor well ?

I will write it again.
I know sensors IP, they have assigned static IP on the router. Flasher is discovering, so do router sensors, with IP which I assigned for static. BUT double click in flasher on sensor doesn’t open sensor page, same when I manually type sensor address in browser.
Sensor are reporting to the sensor community API, their results are visible here on the map, so do in the madavi, either opensensemap - screen below.
The main issue is that when I want to connected within them from local network after few second I have error connection timed out; that’s all what is wrong, nothing else and I would like to know what might be an issue here.
Zrzut ekranu 2022-09-28 085722

If the flasher see the sensors it is a protection in your router. It should open at once.

Is there is any specific port which I should connect? Because this is strange I have many devices in my LAN, like NAS, Home Assistant and their web pages are working without issues. Only here there is issue. Generally sensor pages were available for first 24-48h when I started sensor. I was able to open it and configure sensor. Now after few days of working it is as I wrote before. Meantime I also tried of GPON router so do sensor reboot, but it has no positive effect.

Is there any specific parameter which I may try to change to avoid this connection timed out?

Someone for help ?
Can you read the serial log of the Sensor in USB?

Could you give me a tint how may I read those logs?

I believe I found solution for it. It is quite easy :laughing: wrong power adapter, I used one sensor temporary connected to RPi 3B+ and the second one to wall charger with 1.3A of power. Temporary I switched for one of them power source to strong charger from Xiaomi Mi 11T smartphone and without issues page load after 2sec.
So, no my question is what is minimum condition as power source for this configuration: NodeMCU V3 + SDS011 + BME280 + GPS Neo 6M?

Download the Arduino IDE and use the Serial Monitor with 9600 bauds.

At least 1.5 A to be sure.

1 Like